December 06 2023 03:36:11
· Home
· Articles
· Downloads
· Discussion Forum
· Web Links
· News Categories
· Contact Me
· Photo Gallery
· Search
· Gameservers
Users Online
· Guests Online: 4

· Members Online: 0

· Total Members: 1,124
· Newest Member: Cipyyy12
Teamspeak 3
Last Seen Users
· Silent Bob04:38:14
· Intruder15:28:01
· hackepter15:37:13
· desintegrator19:52:23
· GONZO 2 days
· WEZ 2 days
· Anickaa 1 week
· Homi 1 week
· Sully 2 weeks
· r4vhunter 4 weeks
· Chavez_US 4 weeks
· Nosek 4 weeks
· PSYCHObru 4 weeks
· flip333cz 5 weeks
· The ACE 5 weeks

View Thread: Problem with dedicated server
Vietcong.Info » Vietcong General Discussion » Vietcong Tech Talk
Who is here? 1 Guest
Current Rating: (Total: 0 ratings)  
 Print Thread
Problem with dedicated server
Hey Guys, anybody here with similar problems hosting a dedicated vietcong server?

I 've bought a mini pc which should really do the lifting ( i5-4590T 4 x 3,0 Ghz I 16 GB RAM I 500 GB SSD).

But I can not get the server running. After I click to start the server the vc guard window never opens and ends up in a timeout with the message: game port already bound...
I've added all needed parts like patches, vcguard, vcstarter, opened ports on the router, disabled the windows firewall etc.
I can see that the server starts (using a port scanning tool), but then immediately the connection on port 5425 is lost.

In comparison I'm also hosting a server on another laptop (with much better hardware) without any issues.
It is really weird and annoying because I bought the mini pc to keep it running to host a public server for other players and my guys.

Of course I can still use the server from the working laptop, but I have to close it during the day because I need it for work as well.

Any ideas or hints on what else I could try or look for?
Confused Master
I have zero experience with vcguard, but maybe there is also an option to host using a different port - just like when you (directly) launch vcded.exe.
Edited by Confused Master on 01-02-2023 14:42
Aha ok first of all I thought just by copying the vc guard files into the root directory of the game, will "install" vc guard and when you launch the vcded.exe those settings are applied?

I already tried to switch to another port on all machines. On the working machine it also works on other ports (of course I have to open them on the router before).
But on the two mini pcs it is not working on other ports. I still got the same error message. Which seems a bit generic to me. I guess it always shows that error, when the server could not be started within 15 seconds (at least this is what the readme is telling me).

I really have not idea. I also tried it with a clean v 1.60 version without any modifications. It is always the same process. The vcded.exe starts and there is little traffic on those different ports, but then it just vanishes or probably crashes Grin
Try hosting the server in-game if it displays a different error msg.

Also I recall having UPNP enabled on the gateway router caused similar problems.
Edited by Nosek on 02-02-2023 19:59
That is pretty weird. I disabled upnp and started the server from inside the game. The window stays black, I can access the console and can join from the other laptop Grin

Have to test it out with my buddys. It is even visible on Grin
Jump to Forum:
Similar Threads
Thread Forum Replies Last Post
COOP Player limits on Dedicated Server Vietcong Tech Talk 7 22-08-2022 05:33
Error in server list General Discussion 1 27-01-2022 08:17
can no longer find the server Vietcong Tech Talk 9 18-11-2021 18:49
Vietcong Dedicated Server System Startup Launcher Vietcong Tech Talk 6 27-08-2021 22:24
Problem with walking NPCs in the game. General Discussion 3 26-04-2021 23:43


Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Render time: 0.31 seconds - 54 Queries 4,712,453 unique visits